“International name problem in Portfolio”

  • Krzysztof Rozpędowski

    Hello, When I use special character such as: ą, ć, ż etc... (polish letters) in portfolio-categories. I have to use for ex. "Posilki" instead of "Posiłki". Big difference in our language. Thumbnail wont show in portfolio categories page. In main gallery page, this particular thumbnail is there but smaller than others. Just to sum up, I can't use special character in portfolio categories. What should I change to make it work ? (probably, to read this correctly, theme should use simplified cat.name in a loop instead of original one).

    2:28 on April 22, 2013

  • Zlatan Halilovic

    Hi there,

    please try to make or edit categories by putting their names in the "Name" fields as you would in Polish, but making sure that the "Slug" fields contain the non-polish versions of the names. Here is how the mentioned fields look like: http://awesomescreenshot.com/082179i4ad.

    Once that is done, just replace the following line of code in the taxonomy.php file on your server:

    query_posts( array('post_type' => array( 'my_portfolio' ), 'portfolio_categories' => $term -> name, 'posts_per_page' => -1 ));

    with:

    query_posts( array('post_type' => array( 'my_portfolio' ), 'portfolio_categories' => $term -> slug, 'posts_per_page' => -1 ));

    and you should be fine. 

    Good luck! 

    Sincerely,

    OnionEye

    2:28 on April 24, 2013

  • Krzysztof Rozpędowski

    Ok, great. Thanks for info.

    2:28 on April 25, 2013

  • Zlatan Halilovic

    You are very much welcome! Glad I could be of some help. :) 

    All the best,

    OnionEye

    2:28 on April 27, 2013

Updating...